We regret to announce that Road Test Reports will be closing down on 2nd October 2017

FORD MONDEO questions and answers

Ford Mondeo

Ask and answer questions on a variety of FORD MONDEO models. Help and advice on everything FORD MONDEO. Feel free to ask and answer as many FORD-related questions as you wish.

Ask a question now


Search the questions and answers section:

Below are the latest FORD MONDEO questions submitted by visitors to RoadTestReports.co.uk. To supply an answer, simply click on the "Answer this question" link underneath each question. Alternatively, if you want to ask a question, please use this simple form. Please try to make the question as detailed as possible, with all the information necessary for a comprehensive answer included. Please do not use "text speech" or type everything in CAPS LOCK.

John andersfn, Denmark

Ford Mondeo

Ford Mondeo Mk3 1.8 petrol 2005 that have a rattet Sound when engine is cold, until engine reach temperature it goes away. It appear when the car is driving up hill and pulling. When driving normal the rattle is not very loud. Everything is changed: airtake, air plaps, sparks plugs, ignition etc.

Submitted: 05/09/2017 17:33:14 | ID: 143493

Answer this question

Leigh rhodes, South Yorkshire

Ford Mondeo

Esp light comes on an its comes up engine malfunction and car goes into limp mode

Submitted: 22/08/2017 13:41:59 | ID: 143256

Answer this question

Graham Hossack, Aberdeenshire

Ford Mondeo

My Mondeo automatic sometimes stalls when at idle. This can happen as I pull away from junction or roundabouts etc. What is causing this and how do I get this fixed.

Submitted: 16/08/2017 15:19:23 | ID: 143135

Answer this question

martin oleary, County Londonderry

Ford Mondeo

My Ford Mondeo 2004 tdci has recently caused me problems.The temperature gauge droppes below the 60 marker on the dashboard an sometimes goes completely to the cold.The power then drops in my exceleration an recently the engine warning light has started to come on.Once i pull in an stop driving for a few minutes the temperature gauge will rise again once i start driving to near below normal but then after several miles of driving again it will start to fall again an the power will decrease in my acceleration. What could be the problem do you think? I took it to a mechanic an he suggested it could be a electrical fault an advised me to take it to a auto place to get the wires checked

Submitted: 11/08/2017 16:45:01 | ID: 143070

Answer this question

h Hardy, Devon

Ford Mondeo

This is a problem that we have had 2 years. The dashboard goes all over the place, loose temp, mileage, speed o everything and all fault lights come on. All connectors cleaned and put back, 2 new dashboards put on and same problem. Our mechanic does not know, no fault codes come up. Does anyone know. Car still drives fine even with dash board problems.

Submitted: 01/08/2017 12:27:50 | ID: 142844

Answer this question

Alvin Joseph Levy, West Yorkshire

Ford Mondeo

dose my ford mondeo estate have a tineing belt ?

Submitted: 16/07/2017 21:53:23 | ID: 142591

Answer this question

Alvin Joseph Levy, West Yorkshire

Ford Mondeo

dose my ford mondeo 1,8 estate 06 reg have a timeing belt

Submitted: 16/07/2017 21:50:50 | ID: 142590

Answer this question

Potter, Wiltshire

Ford Mondeo

When I start the engine the boot unlocks and the hazard flashers come on any ideas why???

Submitted: 21/06/2017 21:29:27 | ID: 142062

Answer this question

bob darch, Surrey

Ford Mondeo

When I change down a gear I get a rattling noise that seems to come from the rear but not sure if that is the case. I only get this rattling when engine under pressure after changing down for a few seconds then it is fine Tried revving when stationary but do not get the rattling noise. anyone have any ideas

Answers

Probably the heat shield which is fitted to the exhaust system. Google mondeo exhaust heat shield, they break away at the fixing point due to corrosion and start rattling. Hugh from City of Glasgow

Submitted: 20/06/2017 16:06:13 | ID: 142041

Answer this question

Lorna Robertson, City of Edinburgh

Ford Mondeo

After key fob not working, used key in door and alarm went off. Turned key in ignition to stop alarm, now key won't work central locking system. Anyone any suggestion s??

Submitted: 18/06/2017 22:55:42 | ID: 142016

Answer this question

terry, Essex

Ford Mondeo

I changed the electronic actuator and now the vehicle will not start

Submitted: 21/05/2017 07:33:17 | ID: 141426

Answer this question

Simon, Greater London

Ford Mondeo

The 12v power sockets in the centre consoles have stopped working. looking in the manual there isn't a fuse referred to for these. The only one I can see is "delayed accessory" and is 10amp i'd expect the power sockets to be 15amp. The car is a 2016 2.0 diesel titanium Any help/ideas?

Submitted: 16/05/2017 14:23:41 | ID: 141332

Answer this question

dev, Essex

Ford Mondeo

Mondeo estate 2 l 2010 - The petrol cap FLAP is shut closed - will not open even locikng and unlocking the car repeatedly Is there a separate fuse for this - where is the central fuse box please DEV

Submitted: 10/05/2017 20:31:26 | ID: 141232

Answer this question

peter, West Midlands

Ford Mondeo

when I drive my 1.8 petrol Mondeo zetec my temperature gauge drops right down to cold position would appreciate any help on this issue does the thermostat need replacing or coolant sensor or both its a 54 plate. also had a problem with the car stuttering when I accelerated felt like it was miss firing I changed the coil pack and HT leads car runs smooth coil pack cost £22.00 HT leads £29.98 hope this helps anyone suffering the same symptoms

Submitted: 09/05/2017 23:06:06 | ID: 141202

Answer this question

JAK, Brighton & Hove

Ford Mondeo

my problem started with a high pitch wurling sound comming from engine even when ticking over, and a smell of hot metal, (more then normal engine smell !). took out for a drive around the block and abs light flashed and then car died, tried ignition again and just got clicking, waited a few minutes tried again, car started got home, not sure what to do now asny ideas..

Submitted: 02/05/2017 10:03:30 | ID: 141050

Answer this question

Mark Robson, Tyne and Wear

Ford Mondeo

Put dpf cleaner in tank drove it next day for 4 hours then engine management light came on and car still runs fine any answers please

Submitted: 16/04/2017 13:59:14 | ID: 140672

Answer this question

kevin clements, Warwickshire

Ford Mondeo

my mondeo 2.0ghia has stood for six month i have fitted a new battery but the engine will sitll not turn over

Submitted: 08/04/2017 13:55:12 | ID: 140493

Answer this question

peter greenslade, North Yorkshire

Ford Mondeo

the alarm on the car goes off randomly. how can this be stopped? I am prepared to deactivate the alarm permanently if necessary.

Submitted: 31/03/2017 15:00:34 | ID: 140306

Answer this question

Jackie, Gloucestershire

Ford Mondeo

Hi I recently bought 2013 mondeo diesel from dealership. Almost immediately malfunction light and sometimes management light on. Usually when cold. Doesnt want to start. Runs ok and light go off after stopping and restarting. Main dealers have had it for weeks on and off and say codes dont determine fault! Suggest i drive til it breaks down! £9500 wasted. Anyone help please?

Submitted: 29/03/2017 19:53:37 | ID: 140257

Answer this question

kevin robinson, North Yorkshire

Ford Mondeo

hi ive a Ford Mondeo 2010 estate i got engine malfunction light up took it to garage for diagnostic came up DPF blockage so garage reconditioned DPF and we put new map sensor on too , it ran great for 50 miles or so then engine malfunction appeared again took it back to diagnostics and same code appeared soot / DPF the mechanic said its got him beat because he knows the DPF is clear and the car runs brilliant any ideas on what else could be problem and is there a service reminder code on fords kind regards kev

Answers

Did the mechanic code the new DPF into the ECU? He has to do this under the cars diagnostic system and it should really have been done before the car was driven otherwise you can waste the new DPF. Hugh from City of Glasgow

Submitted: 29/03/2017 09:38:27 | ID: 140236

Answer this question

Jason Scott, East Sussex

Ford Mondeo

My "engine malfuntion " warning light came on, during a journey. It was amber, and i managed to get home. The problem was a loss of power, especially going up hill. What could be the cause of that ?

Submitted: 27/03/2017 10:12:02 | ID: 140184

Answer this question

CHRIS CAIRNS, County Tyrone

Ford Mondeo

How does fan belt go on

Submitted: 19/03/2017 21:56:27 | ID: 140011

Answer this question

Stuart, Dorset

Ford Mondeo

Mondeo 1999 2.0 ltr SI, with difficulties from exhaust gas regulator, I believe. Car starts and idles ok! But when I move off after about 3-400 yes engine seems to drop off slightly in speed and To maintain same speed I have to increase revs. Within a short distance the car starts to kangaroo as though there is a fuel problem. When I stop on three occasions I have noticed that one of the rubber hoses that seem to run eventually to the PP-GF30 Exhaust Gas recycling regulator has blown off. ( Ford part no.1053801) It seems after this to be difficult to get above 2500 - 3000 rpm and I have had to replace the rubber hose from the exhaust to the EGR because it was beginning to break from heat generated. The car is in overall good condition and has been a real delight when it runs properly. Surprisingly even with these problems it has gone through an MOT and is therefore good foe another 12 months. Apart from scrapping it has anyone got anyone got any suggestions as to remedial action, that might be effective in restoring my SI

Submitted: 17/03/2017 15:03:26 | ID: 139935

Answer this question

John Stewart, Angus

Ford Mondeo

On initial start up first thing in morning there is a chirping sound from the engine. This sound only happens if the engine has been switched off for 6 hours or longer. Would appreciate any comments on what this can be and if it is serious to continue driving my car.

Answers

Could be a leak from the exhaust manifold, possible one of the gaskets has gone or is missing. Hugh from City of Glasgow

Submitted: 07/03/2017 12:14:32 | ID: 139577

Answer this question

Bob baldock, Surrey

Ford Mondeo

I have replaced the fuel pump and filter and as told the pump was faulty but it sounds as though the pump is not working any idea's

Submitted: 26/02/2017 13:41:50 | ID: 139207

Answer this question

Ray, Essex

Ford Mondeo

I've been having problems with the car jumping then starts to cut out I've change the spark plugs no change any idea wht this could be

Submitted: 21/02/2017 09:15:29 | ID: 139085

Answer this question

Amran Janjua, South Yorkshire

Ford Mondeo

Hi I have a Ford Mondeo 62 plate and few questions. As like the ford Focus & Cmax 62 plates onwards when you look the cars with remotes the headlights stay on for 30 seconds before going off which is normal. My Mondeo does not do this neither on opening or locking. Are the light supposed to stay on for 15/30 seconds upon locking & opening my Mondeo?

Submitted: 10/02/2017 14:32:16 | ID: 138861

Answer this question

Tony Crome, Devon

Ford Mondeo

When I indicate right , a beeping alarm sounds , in time with the indicator . Indicating left is fine . Checked bulbs , they are flashing . When I have dipped headlights it doesn't happen .

Answers

Is your car fitted with a towbar & electrics? If so it might have an indicator warning buzzer fitted which could be faulty if it's operating when a trailer isn't plugged in. Mick from Portugal

Submitted: 03/02/2017 14:52:34 | ID: 138641

Answer this question

mick, Hampshire

Ford Mondeo

ford mondeo 2.0ltr 2001 abs light comes on when you switch on any instrument then engine stalls and will not turn engine over

Submitted: 25/01/2017 08:33:57 | ID: 138388

Answer this question

Sandro Centola, Midlothian

Ford Mondeo

my battery light kept coming on and off in my 2004 130bhp ford mondeo,my mechanic told me it was alternator problem.i had no problem with the car starting but in new years day a burning smell was coming through and i could see my windscreen wipers and heater going very slow. i went to my sister in law's house and when i came out my car would not start.put battery charger on for 20 minutes and still would not start.tried to jump start and still nothing,called in AA and charged battery with booster for about 20 minutes and still would not start.towed car to my mechanic and on the 3 of January got new alternator not put on as my mechanic cannot get the car going to see what is going on, he is saying to me now that it could be engine problem. on forums what i am getting back seems to be ecu or smart manager loom.any advice please i hope it not engine problem

Submitted: 08/01/2017 16:11:16 | ID: 137937

Answer this question

Sandro Centola, Midlothian

Ford Mondeo

my battery light kept coming on and off in my 2004 130bhp ford mondeo,my mechanic told me it was alternator problem.i had no problem with the car starting but in new years day a burning smell was coming through and i could see my windscreen wipers and heater going very slow. i went to my sister in law's house and when i came out my car would not start.put battery charger on for 20 minutes and still would not start.tried to jump start and still nothing,called in AA and charged battery with booster for about 20 minutes and still would not start.towed car to my mechanic and on the 3 of January got new alternator not put on as my mechanic cannot get the car going to see what is going on, he is saying to me now that it could be engine problem. on forums what i am getting back seems to be ecu or smart manager loom.any advice please i hope it not engine problem

Submitted: 08/01/2017 16:04:53 | ID: 137936

Answer this question

Mihail, Norfolk

Ford Mondeo

Hello.cylinder 1 fail to start and car is working on 3 cylinders,smells strong of petrol from exhaust and have no power. Car starts from everytime and mooving. Sometimes on high rpm power kicks in.have some nasty knocking from engine but very quiet, only when car is on neutral gear.someone have idea what could be the problem? Thank you.

Submitted: 07/01/2017 00:32:21 | ID: 137884

Answer this question

Ben, West Midlands

Ford Mondeo

Can you tell me if there is some kind of bearings, by the steering wheel, because she. I start the engine, I hear s churning like noise? Thanks

Submitted: 05/01/2017 21:38:03 | ID: 137849

Answer this question

john, Hertfordshire

Ford Mondeo

when using my ignitionkey the lights on dashboard work but engine wont fire normally takes 4or5 goes

Submitted: 01/01/2017 13:33:50 | ID: 137707

Answer this question

dave hillyard, Durham

Ford Mondeo

when i start the engine up all the lights go out except the battery and engine management lights they stay on for about 20 seconds and while they are on i can't do anything when they go off i can then drive away. also when driving at low revs between 1000 and 1500 the battery light comes on i have to stop the engine and restart to take battery light off i had a new allternator fitted recently this problem has started since then

Submitted: 07/12/2016 11:10:26 | ID: 137220

Answer this question

Hugh, Warwickshire

Ford Mondeo

My mondeo 51 plate keeps stalling at 2000 revs and steering wheel locks up, the engine management light has come on also, it drives but only below 2000 revs any ideas what the problem could be, thanks.

Submitted: 26/11/2016 17:40:51 | ID: 136977

Answer this question

kris maguire, Dorset

Ford Mondeo

Hi Just had a clutch fitted and now runs very loud any ideas. Thanks Kris

Answers

Check the rubber seals on firewall around the steering shaft, brake pedal. martin from Flintshire

Submitted: 20/11/2016 12:19:08 | ID: 136816

Answer this question

julie, Greater Manchester

Ford Mondeo

Hi I have a Mondeo 58 plate. Last night whilst out driving the dashboard lit up with all the symbols on it. Ie engine light. Seat belt light does ext for a few seconds then went off. The power in the car didn't change out the head lights didn't dip but the mileage gage that tells you how much petrol you have changed to temperature of 54 f.. Could anyone let me know if they have had this problem and is the car safe to drive as I don't know what's wrong.

Submitted: 30/10/2016 18:18:50 | ID: 136368

Answer this question

Howard, Nottinghamshire

Ford Mondeo

On start up and during the first couple of miles engine sluggish when depressing accelerator, any ideas.

Submitted: 16/10/2016 14:47:10 | ID: 135997

Answer this question

Arye, Israel

Ford Mondeo

I have three questions, please: 1. There are two thick pipes that are connected to the upper area of the expansion tank. One is above the other. One comes from the input of the radiator, the second comes from the bottom of the engine. Does it matter what pipe is above the other? 2. The pipe that comes from the input of the radiator, it seems to me that it bypasses the radiator, is always cold or much colder than the other pipes in the system. Is it OK? If it is not, what should I do? 3. The fan starts to run when the coolant is 107 Celsius. I am afraid that it is too high. The coolant goes to 108 Celsius, the fan starts to run and the temperature drops to 100 - 102 Celsius, warming again to 108 and so on. Thank you very much, Arye

Submitted: 07/10/2016 12:30:47 | ID: 135773

Answer this question