SSANGYONG

Select a model

SSANGYONG questions and answers: find help and give advice

Ask and answer questions on a variety of SSANGYONG models. Help and advice on everything SSANGYONG. Feel free to ask and answer as many SSANGYONG-related questions as you wish.


Search the questions and answers section:

Below are the latest SSANGYONG questions answered by visitors to RoadTestReports.co.uk. To supply an answer yourself simply click on the "Answer this question" link underneath each question. Alternatively, if you want to ask a question, simply click on the link below.

Ask a question now

Lorna gilmour, Falkirk

Ssangyong Tivoli

How do you open the key fob to change the battery

Answers

How do I change the key fob battery? John park from Oxfordshire

First flip the key to the open position. Put a coin or flat blade screwdriver in the empty space. Leaver off the back (opposite side from buttons) change battery immediately Cr 2032. Replace rear plate. Ron Tennant from Aberdeenshire

Submitted: 28/06/2017 18:21:26 | ID: 142234

Answer this question

Joseph, Malta

Ssangyong Rexton

The 4wd light comes on the dash now and then without engaging the 4x4 button, I am afraid that should it engage on its own at high speed, it will damage the diff and drives shaft, what could be the problem ?

Answers

HI JOSEPH, DID YOU EVER GET TO THE BOTTOM OF THIS ISSUE, IF SO WHAT WAS THE CAUSE AND FIX. ANY HELP WOULD BE GREATLY APPRECIATED. CHEERS, JORDYN JORDYN from Australia

Submitted: 31/08/2017 13:01:59 | ID: 143413

Answer this question

Glenn, Australia

Ssangyong Kyron

G'day. My problem is with the temperature gauge. From a cold start I can drive all day, but once I stop the engine for a bit and then start the car the temp gauge alarms after about 7-8 kilometres . I can pull over, stop the engine/ re-start and all is fine for another few k's then alarm sounds again. The car is running fine, its not overheating at all. Any Ideas ???

Answers

Hi Glen, did you sort out the problem? I am experiencing the same problem and seeks help? wayne from Stockton-on-Tees

Hi Glen, did you sort out the problem? I am experiencing the same problem and seeks help? wayne from Stockton-on-Tees

No Wayne, I have not sorted this problem yet. Glenn from Australia

Hello Glenn of Australia and Wayne of Stockton. I owned the Kyron 2.0 (2007) since 2010, bought it pre-owned. I had the same issue with "overheating" which the mechanic is not able to diagnose with their "Handheld Computer". I endured this issue for many, many months and no one from the service centre seem to know what to do. One of my "Expert Foremen" who takes care of my other Ssangyong car, REXTON, suggested that I change all the relevant sensors that control temperatures. He says after all these sensors are relatively cheap and the car has been around in this tropical climate with temperatures hitting 33 degress Celcius or above all year round. It could be faulty and the computer unable to detect. So, with the much needed advice, I changed the Radiator Sensor, Engine Sensor and one other sensor that controls overall temperature of the system. Guess what, the car ran like a dream till now, four years later, with NO overheating or stalling issues. Don't wait, go change these sensors. Take care and enjoy the trouble free drive. Cheers! Melvin Lee from Malaysia

I've been experiencing the same 'overheating' issue on my 2009 Kyron 2.0XDi Automatic (4x2). I've just had it serviced, had the radiator flushed and topped up with a 30/70 (coolant/water) Castrol Radicool SL mixture. My mechanic had even reset the fault on his handheld diagnostic machine. The alarm now seems to be activating more often than before. I have to pull over on the highway, switch off and restart to clear the fault - the temp then reverts to normal (just between half and quarter). I will try and do the sensor renewal and see how it goes after that. Thanks Melvin Lee from Malaysia for your suggestion. Andrew from South Africa

I've been experiencing the same 'overheating' issue on my 2009 Kyron 2.0XDi Automatic (4x2). I've just had it serviced, had the radiator flushed and topped up with a 30/70 (coolant/water) Castrol Radicool SL mixture. My mechanic had even reset the fault on his handheld diagnostic machine. The alarm now seems to be activating more often than before. I have to pull over on the highway, switch off and restart to clear the fault - the temp then reverts to normal (just between half and quarter). I will try and do the sensor renewal and see how it goes after that. Thanks Melvin Lee from Malaysia for your suggestion. Andrew from South Africa

Had the same problem,changed one of the sensors but didn`t help,ended up being the thermostat ,replaced it and problem stopped Greg from Australia

Yes it's the thermostat.. the thing is failed open and the engine is running too cool.. The dash temp gauge should show about half way, not down at a third. The crappy electronics in these cars sense an anomaly after you have stopped on your journey but the only thing the system is programmed to warn you about is overheating.. so that's what you get.. get the thermostat replaced if you can find someone willing to do it.. I couldn't, so I installed an inline high flow 80 degree C thermostat it the upper hose.. with a small hole in the base of the thermostat flange to enable a little flow in the hose.. No more problem.. Geoff Stevenson from Australia

Believe it or not, this problem is caused by a faulty thermostat, it allows a hot-spot to form under the sensor, steam from that hot-spot flows straight over the temperature sensor, sending the temperature guage crazy, which fools the engine managment into thinking the sensor is faulty. Change the thermostat first, before buying expensive sensors. I have personal experience with this on several vehicles, all of which were cured by changing the thermostat. Trevor Marron from Northamptonshire

Submitted: 21/05/2014 04:31:57 | ID: 95821

Answer this question

Sunny, Australia

Ssangyong Rexton

Hi, I have 2004 Rexton RX320 Sports, I am confused about using the gear modes, should I use 'S' mode or 'W' mode? As I have seen many people saying different things about the 'S' mode, some calls it Standard, some calls it Sports and few said Summer as 'W' stands for Winter. My car is consuming too much petrol which is much more than it should be, which gear mode will help me to get better fuel economy, any other things which would help me? I am usin W mode at the moment as I think it is slightly better than the S mode. As it is the start of winter here so I can use Winter mode but should I use the same in Summer too?Suggestion will be much appreciated.

Answers

W mode is for Winter, when selected the vehicle starts from 2nd gear and reverse using the 2nd Reverse Gear provided in MB gearbox. This is to prevent wheel slip. S is Standard Mode. Kapila Jayasundara from Sri Lanka

Submitted: 06/05/2017 04:04:00 | ID: 141117

Answer this question

Jan, South Africa

Ssangyong Kyron

Car 2.0 diesel xdi does not want to start, checked and tested and saw that injectors are not getting any signal to open, what can be faulty? Diesel pump is working fine. new turbo, timing etc is correct

Answers

Hi Jan did you find the answer ? My kyron doing same, turns over but no signal to the injectors. Replaced pump and fuel rail, still no power to injectors to fuel engine. Also obd scan won't connect to computer, works ok with same model action. Everything else works just no signal. Colin from Australia

Did you have any luck repairing the Kyron. I have the same problem. Kelvin from Kent

Submitted: 20/02/2017 06:00:48 | ID: 139052

Answer this question

Phil, County Londonderry

Ssangyong Kyron

I have a 2006 Kyron, the fan is has excessive noise, i.e. Whirring can I do anything about to make it less noisy.

Answers

Hi if it goes louder with speed it most likely the viscous coupling not free wheeling smoothly, have replaced 2 of these in recent months you can get them from e bay, mine usually come from Poland same as a mercedes ml Paul Tallents from Lancashire

Hi, Simple solution: throw out the viscous coupling altogether, including the fan blades. I am using my Actyon without this coupling (which was replaced twice before and became very noisy again and again) for two or three years with no problem with cooling at all. My coupling was manufactured in Germany. Joseph Joseph from Australia

Submitted: 11/01/2017 21:29:46 | ID: 138031

Answer this question

Titus, Wiltshire

Ssangyong Turismo

Hi. Airbag icon is lighting on the dashboard. I had same issue with Rexton W but can't remember how it was solved. Any ideas? Thanks

Answers

Check your fuses to see if ther is an airbag fuse. If OK then try disconnecting battery for 10 minutes then reconnecting it to reboot the system Check also beneath the drivers and front passengers seats for the yellow wiring connectors being securely connected. Hugh from City of Glasgow

We had same problem. The wiring for airbag is situated under the ppassenger seat and the airbag warning light came on after we ut the seat back. Turned out to be a loose connection in wiring. Hope this helps. Callsey from Oxfordshire

Submitted: 25/04/2017 17:55:56 | ID: 140898

Answer this question

Pedro, City of Glasgow

Ssangyong Tivoli

Engine Management Warning light comes on - screen briefly displays words to the effect of "Check Engine Management System". This has now happened twice. The first time was actually the day before the car was going in for it's first service. I asked the garage to have a look at this but while I was making my way to the garage the warning light went out and when the garage looked they couldn't find any reason for the light activating. The problem recurred today and yet again when I stopped the car for a few minutes and then restarted the light went out. Any ideas what the problem might be? It doesn't instil a feeling of confidence in the car when I constantly now find myself glancing at the warning light to see if this has activated again!

Answers

Hello Pedro, Did the problem get resolved? My car is less than a year old (just over 9,000 miles clocked) and the same warning light came on. I'm booked for a service but worried that there may be something wrong. Joe T from Lancashire

Submitted: 13/06/2017 21:30:06 | ID: 141916

Answer this question

J Hartley, Darlington

Ssangyong Turismo

Hi, How do I change the bulbs in the headlights? The owners manual does not include instructions on how to do this. Do I have to remove the headlight in a similar way to a Kyron? Thanks

Answers

Hi there,J Hartley. Ref your lights it does refer to your headlights chapter 13 although the drawings and photographs are a bit to be desired. You simply remove a round plastic part at the back of the headlight and you do not really actually need to remove the unit itself, as all bulbs, (except the fog light), can be accessed via this opening its about the size of a tea caddy and it screws on/off, located however in the centre and at the back of your headlight unit, however if your like me and have big hands/fingers, you will struggle to get the job done, better to recriut some other member of the family if you have one, to do the bulb change as its very tight for space to manipulate around in the space provided, but of course, you could by just removing the light unit altogether and part of your problem is deleted then. I do hope it helps, although unfortunately, no doubt you will have found out before now, having just checked the date for your question, sorry. James from Scottish Borders

Submitted: 08/08/2016 12:54:12 | ID: 134195

Answer this question

Hannah, Tyne and Wear

Ssangyong Tivoli

Hi everyone! Just got my new Tivoli but have absolutely no idea how to change the lighting colours behind the speedometer, googled it until I'm blue in the face and can't find it in the user manuals. Thanks for the help :)

Answers

If you go onto the button under the radio settings called trip button and press until the cluster setting comes up on speedo behind steering wheel then press set to show what colour u would like. Mandi from Bristol

I just got my new Tivoli yesterday. So pleased with it but hate to see what can go wrong with it. Only a year old. Glynis from Essex

Submitted: 03/09/2016 19:05:51 | ID: 134887

Answer this question

Keith, Essex

Ssangyong Rexton

Hi Cruise control just stopped working is there any thing to look at Thanks for any help Monty

Answers

i have the similar problem but with mine cruise control works ok for about 5 miles then drops out and will not work again till next day.....only thing i did was tyre fitted wrong size tyres to front and problem started but didnt realise wrong tyres were fitted till three or four weeks later..correct size tyres now fitted but cruise still not working correctly... can anybody help? clive from Nottinghamshire

Submitted: 29/04/2017 00:25:54 | ID: 140990

Answer this question

Kevin Laurie , New Zealand

Ssangyong Rexton

I have a 2005 rexton 270xdi and for the last year I have been having acceleration problems. When I accelerate after slowing down at all speeds the car will not accelerate at all .I can berry my foot to the floor for up to 30 sec with nothing more than an idle before it slowly starts to Rev and eventually it will boost and take off .Any ideas?

Answers

Kevin did you get this sorted? Could be dirty MAF sensor or vacuum modulator for turbo Russell Gorst from New Zealand

Submitted: 25/02/2017 03:39:49 | ID: 139167

Answer this question

Keith, Ireland

Ssangyong Rexton

Hi my 06 Renton was finding it hard to stArt especially In The morning. The battery was goi g dead i the mornings so i jumped it of the van and away sbe would go. I thought it was the battery. So I changed the battery and now it won't start at all it turns over Strong but just won't fire. Any help greatly appriated. Thank you

Answers

Do you have a warning lights showing (orange key indicates immobiliser)? If not check the engine is getting fuel. Mick from Portugal

Hi Keith, I've a 2007 rexton and the same thing has happened mine!! Battery went flat, changed it now it just cranks over! The orange key immobiliser light is on in my dash but have had the keys tested and its married into the ecu ok! Just wondering did you get yours going again and if so what did you do to fix it?? Cheers Calvin from County Down

Submitted: 05/03/2017 18:50:41 | ID: 139525

Answer this question

John, Warrington

Ssangyong Tivoli

I've just bought this vehicle new last week and I'm having real problems with the hand brake. When I am stationary ready to park I am unable to pull up the hand brake and it stays there. I have to do this action several times to get it to stay. It's just rolled down the path now I need so help.

Answers

I have had a Tivoli for 1 year now, the handbrake is a constant cause of concern, it has been looked at several times and "adjusted" last week it rolled down my drive and hit the house damaging the car... something is NOT right... I am awaiting comment from the dealership where I purchased the vehicle.. Derek Francis from Worcestershire

Hi, we have had our tivoli since April 2016, it went in on a recall, while it was in the garage, they changed the button on the handbrake, as this was known to be a problem. We have also had drivers door handle replaced, and will have the other 3 done when it goes in for a service. They don't open the door immediately, so you have to do it again, otherwise a nice car. Hope this helps. Graham Graham Love from Norfolk

Submitted: 27/03/2016 20:24:33 | ID: 129537

Answer this question

turner omoyele, Nigeria

Ssangyong Rexton

my rexton jeep 2010 jerks alot and i have changed the coils, fuel pump and serviced the nozzles and injectors but it still jerks what more should i do. please i need your help.

Answers

Water in d tank.Therefore in d engine compartment in d bonnet there's fitter sepration to dry d water off by squizzing d fitter under bonnet and problem solve orla from Greater London

Submitted: 24/05/2016 10:46:05 | ID: 131950

Answer this question

edward Osei Kofi, Ghana

Ssangyong Rexton

For two weeks now, my gear box changes to the first gear and does not change again.Any ideas of how to fix it?

Answers

If you have a automatic gearbox, then I had the same problem. There is a control box that sits above the automatic transmission. The seals on this box give out and allow hydraulic oil in to flood the controller. I managed to nurse my car around for a while but you will need to change this sooner rather than later. Most garages will not know how to fix and will not touch the problem... I found a specialist automatic transmission specialist that had worked on Mercedes transmissions that knew exactly what to do... (R) RWood from Greater London

Submitted: 10/11/2015 14:05:05 | ID: 123368

Answer this question

Keith, Essex

Ssangyong Rexton

Hi Have noise when turning steering to right only to right it does not happen till you have about 7 miles the further you go it gets I can only say it is a grouchy noise has anyone had this fault themselves it only happen while moving. Monty

Answers

Hi, yes I have had a similar problem like this, grouchy sound when you steer the car, left or right. My mechanics checked it thoroughly and still couldn't find out what this noise was, hence they said it might be needing oil in the steering wheel bearing or something minor. Ani from Poland

Submitted: 21/10/2016 01:11:54 | ID: 136105

Answer this question

Peter, Australia

Ssangyong Kyron

Hi My Kyron Kick down not working. When slow down and accelerate, it is not change to low gears. I took to few mechanics they could't find the fault. please advise me.

Answers

I have just had a very simular issue it sounds like the TCU has failed or it needs to be reprogramed if this does not work you may need to purchase a new TCU ( transmission control unit ) and then have it programed to suit your model , the best way to do this is take a photo of your old TCU which is located on the passage side in the in the fire wall under the carpet and then supply the parts people with the photo so they can supply the correct part ward from Australia

Submitted: 13/07/2016 12:06:38 | ID: 133485

Answer this question

Lee, Nottinghamshire

Ssangyong Rodius

Fitted new glow plug now engine won't start,when fitted had to move injector cables any ldeas

Answers

You are much better to replace heater plugs in sets but also injector harnesses can become brittle with heat, they are often stretched tight and connections become loose or affected by dampness. Release the cables and check them thoroughly for any signs of cracks or damage. Failing that, try replacing the old heater plug in the engine and see if it starts. Hugh from City of Glasgow

Submitted: 29/03/2017 15:58:56 | ID: 140249

Answer this question

Mr. Zul, Brunei

Ssangyong Rexton

My Ssangyong Rexton 290 got problem with auto gearbox. I put on 'D' , its move gently normal and cruise with normal speed changes no problem at all. But when I put on R, the gearbox has no respond to move, no sound of engage of gear. On top of that, the front panel clipping light 'R'. Please advise and comment this matter. Thank you.

Answers

Can anyone please help me? I have the exact same problem with reverse gear nakul from India

i have the same problem my car today have a problem in the gear box , i put in N my car move D,1,2,3 my car also move if i put the R my car not moving at all but i dont have the clipping light R !!!!!!! ramzi from Qatar

Submitted: 04/06/2014 03:09:57 | ID: 96857

Answer this question

Anthony Proctor, Ireland

Ssangyong Kyron

The master switch for the windows in drivers door will only operate 1 of the other windows .. Ive tried a different switch but its exactly the same problem. Each window Does work independently on its own door switch .. But drivers door window does not work at all !! Any help please ?

Answers

I had the same problem on my Kyron and the wires in the loom from the door to the car body were broken. I removed this loom from the car dooe and unpluged it from the point it enters the car body. There were 6 wires broken from opening and closing the door over the years. The copper stranded wire is too stiff and snaps over time. I soldered the damaged wires and fitted everything back. All window functions are now working. Leonard from Ireland

Submitted: 10/06/2016 21:19:28 | ID: 132541

Answer this question

John, Durham

Ssangyong Korando

At a recent first mot I had an advisory regarding wear on the inside of both rear tyres. I spoke to my dealer about this and he said it was normal for the Korando. This seems a bit strange to me, has anybody else had this experience?

Answers

I've no experience of the Korando but I have experienced the same with BMW 5 series (E28 & E34) it was just the way the rear suspension had been designed. However for your piece of mind it wouldn't cost too much to have the rear alignment checked. Mick from Portugal

Submitted: 01/03/2017 16:47:23 | ID: 139338

Answer this question

paul, Stockton-on-Tees

Ssangyong Rexton

56 plate Rexton 2.7xdi, check engine light comes on at idle, when drive away it goes out. Unless I accelerate hard then it comes on and stays on. Car is flat and won't accelerate it struggles to get past 50mph!

Answers

hi will be a split vacuum pipe had 3 rextons same problem paul paul from Surrey

Submitted: 25/01/2017 04:59:10 | ID: 138384

Answer this question

Stewart McFadyen, Australia

Ssangyong Rexton

red light stays on left side engine compartment abs/esp lights stay on dash

Answers

red light stays on left side of engine also abs esp hdc lights instrument cluster on dash Stewart McFadyen from Australia

Submitted: 11/12/2016 05:53:51 | ID: 137305

Answer this question

Chris Collingwood, Lancashire

Ssangyong Rexton W

Rexton W is now just over 2 years old and 20,000 miles Last 8 months it has developed a noise like a rattling heat shield only when driven It has been back to dealer and I have had it on Axle stands but neither of us can find the fault. According to the dealer they have or indeed are not aware of another Rexton with this annoying rattle. Anybody else have this problem if so I would love to know! Thank you

Answers

I once had a similar rattle, albeit on a Cavalier, it turned out to be a loose baffle in the silencer box. Mick from Portugal

Submitted: 07/02/2017 12:46:15 | ID: 138771

Answer this question

Irfan Lok, Malaysia

Ssangyong Rexton

I am selling my SUV. I can not locate the engine number location. Can you tell me where is the engine number location?

Answers

The engine number is located near side front behind the front wheel just above the chassis, you will need a light has it is hard to see. Harold from Renfrewshire

Submitted: 06/01/2017 08:12:22 | ID: 137857

Answer this question

Mark, Argyll and Bute

Ssangyong Rexton

Hi, I have a beeping sound every few minutes And red light comes on ( shape of a head with a works helmet on) . I've took to a garage and had a diagnostic test done and they don't know what it is and said I need to take to Ssangyong dealer. Car still runs ok but want to know is this serious and how can I get this rectified as very annoying ?? Thanks, Mark.

Answers

It's a water separator light which can mean the fuel filter is choking up a bit or you may have water contaminated fuel in the tank. There is a procedure to clean water out the filter that is in the manual but if after that it still comes on it will be water in tank or fuel filter needing replaced. Down in Dunoon if it helps. Duncan from Argyll and Bute

Submitted: 22/10/2016 09:16:48 | ID: 136132

Answer this question

boden7@gmail.com, County Antrim

Ssangyong Rodius

My son has just bought a Ssangyong radius 2002 27d,the gear stick is fully wabble.can you help.Geoff

Answers

At the top of the gearbox is a u shaped joint that connects the stick to the gear box. This is held in by a small pin and c clip. The c clip will have rotted away and the pin will have slipped out. It can be done within dropping the box using mirrors and a lot of patience. I repaired my 2005 s model like this. It is tricky but can be done. Look on internet at gearbox for sale and you will see the Y shaped joint. Simon from Greater Manchester

Submitted: 14/02/2015 11:12:29 | ID: 111503

Answer this question

Paul mansell, North Somerset

Ssangyong Kyron

Hi on the side of the steering column by the audio controls is a switch which says PWR can you tell me what this switch does

Answers

That switch turns your radio off and on. Handy when you need to consecrate on reversing. Craig from Somerset

Submitted: 01/11/2015 18:29:50 | ID: 122989

Answer this question

Vincent, Australia

Ssangyong Rexton

Vehicle starts and runs for a few minutes and then stops. Will not restart. Left for a few minutes will start but will stop after a few minutes. Fuel relay is hot, but swapped, still does the same.

Answers

How did you go with this problem mate, it sounds very much like the solenoids. Brian from Australia

May be the crankshaft sensor. Mine had a crack in it so would disconnect when hot and cut-out the engine. When cold would start no problem Richard from South Africa

Submitted: 18/07/2016 03:18:18 | ID: 133609

Answer this question

neil, Merseyside

Ssangyong Kyron

Hi I have the kyron 2009 2litre xdi model. After driving for 5 mins the glow plug light comes on and stays on. Is it telling me there is a faulty plug or are they actually on? Don't want to drive if heating all the time... Also do you think they will be seized as car has done 70k and not sure when last changed? Thanks

Answers

i had the same problem. i checked which glow plugs did not function and changed 2 of them. Glow plugs are cheap about £15 each. go to youtube and you will find how easy it is to change it. 10 minute job. AHCENE NAZEF from Lancashire

Submitted: 31/03/2016 01:55:37 | ID: 129721

Answer this question

Neil Baddeley, Staffordshire

Ssangyong Kyron

I've just got my first Ssangyong and everything is fine apart from every now and then, key goes in, turn, engine kicks in fine but then the alarm goes off but engine is still running. It doesn't cut out. With not knowing that much about the car, I press this button, that button. Turn engine off. I can't seem to find what actually deactivates the alarm when it goes off spontaneously. Any advice would be greatly appreciated.

Answers

I would diactivate the alarm. It is under the bonnet. ask any garage to do it. it is a 10 minute job. No more problem with sounding alarm. I had lots of problems when leaving my dog in the car. There must be an internal sensor which will set off the alarm. now problem solved as i don't really need the alarm. AHCENE NAZEF from Lancashire

Submitted: 24/08/2016 23:13:56 | ID: 134625

Answer this question

Dee, Ireland

Ssangyong Rexton

Where can I get a Replacement alarm fob, Not the Ignition Key Immobiliser but the 2 button alarm fob. Cant find one anywhere.

Answers

i got a replacement fob off ebay around £30 its a cobra alarm or look on cobra alarm website joanne from Derbyshire

i got a replacement fob off ebay around £30 its a cobra alarm or look on cobra alarm website joanne from Derbyshire

No its not a cobra alarm. Its a factory fitted alarm system, I still cant find a FOB (Remote) for it.. I'll keep looking and post any results.. Dee from Ireland

I meant to say, thank you Joanne for replying.. Dee from Ireland

The factory fitted alarm on a 2004 Rexton is a Cobra alarm, Joanne is correct. steve from Bath and North East Somerset

Submitted: 26/01/2015 23:49:43 | ID: 110357

Answer this question

Kenneth, Dominican Republic

Ssangyong Rexton

Hello I have a 2008 Rexton Turbo Diesel and my Launch is really slow, After it hits 1800 RPMs it runs great but before that it is a Turtle. Any advises_? also my Steering is leaking, before i had to refill it once every 2 months but this week after i used the 4x4 i had to refill it right away and noticed it leaked a whoole bottle in a day, last year it leaked a bottle in a few days but after 3 bottles it went back to leaking a whole bottle in 3 or even 6 months, but today it is just insane. Any help?

Answers

Check or disconnect your EGR solenoid vacuum valve (electrical plug).Quick fix. Raynold from Trinidad and Tobago

The Steering Cap spring was too hard, i punched a hole in it and not leaking any more, thanks on the EGR i will try this now. Kenneth from Dominican Republic

Submitted: 13/09/2016 22:37:56 | ID: 135167

Answer this question

Josh Wiggill , Herefordshire

Ssangyong Rexton

Hi, I have a 2004 Ssangyong Rexton and this morning when I started it up it was very shaky and lumpy, I turned it off and started about 1 minuet later and it was still the same, shaky and lumpy, upon leaving it for 6 minuets it had stopped and returned to its normal self. Do rextons have coils, if so could it be this going, if not what else would it possibley be. Many thanks Josh

Answers

Need to program the keys. I have a scan100 but it needs an access code. lnnocent from South Africa

Submitted: 09/08/2016 10:07:18 | ID: 134219

Answer this question

Steve, Australia

Ssangyong Rexton

Hi , our 2010 rexton drives very well , however when just crusing or setting off for a split second it seems to be a delay in the gearbox picking up the gears ,this happens when accelerating for a split second (automatic box )

Answers

Check to make sure you have the correct ATF in it, some dealers and machanics use the near enough is good enough, the 2010 Rexton digital gearbox was the last series of Mercedes Benz gearboxes used before merc sold it. Brian from Australia

Submitted: 26/02/2016 23:43:38 | ID: 128229

Answer this question

ray logan, Australia

Ssangyong Rexton

how can i stop the car alarm from going off constantly i would be happy to just disconnect it .the slightest bit of wind will set it off hope you can help thank you.

Answers

The main culprits are there light sensors that the doors close on, check which one doesn't turn the interior light on, there's also a spring sensor under the bonnet as well, also check the rubbers that your bonnet shut on to are even. Brian from Australia

Submitted: 21/08/2016 07:11:30 | ID: 134520

Answer this question

Kevin Keane , Ireland

Ssangyong Rexton

I have loud squealing noise coming from fan belt, and when I look down the pulley below and slight left of power steering seems to be out of line. Is this the tensioner and would this be the problem? If so is it a big job to change it? I presume it's fan and cowling out job?

Answers

Yes, most likely a worn belt tensioner, not too big a job. Raynold from Trinidad and Tobago

Yes, most likely a worn belt tensioner, not too big a job. Raynold from Trinidad and Tobago

Submitted: 21/11/2015 08:58:37 | ID: 123754

Answer this question

Robert McConnell, Antrim

Ssangyong Rexton

My automatic operation on the doors are not working properly, occasionally the lhs both doors won't lock or open when using the key fob, the drivers door won't lock, it won't even let me push the locking knob. The rhs passenger door and tail door work ok, but they all make a terrible grinding noise. Fuses all ok, did key fob reset, no diff, disconnected and reconnected the battery, again no diff. Anybody any ideas.

Answers

Need to replace your affected door lock actuators. Raynold from Trinidad and Tobago

Submitted: 16/05/2016 16:33:31 | ID: 131590

Answer this question

Karen, Shropshire

Ssangyong Rexton

I can't get in the car.....neither of the remotes will unlock the car. The red light on remote working but not opening the car. If I use the key to open the door the alarm goes off until I close and manually relock the door. Hoping someone can help ??

Answers

Hello I have a Rexton myself also had same problem. The remote needs programming which you can do with just key and fob. If I remember you hold the fob button down when you turn key on until light on fob stays on and same on second key that's it. Anthony from Shropshire

Submitted: 26/06/2016 14:14:45 | ID: 133014

Answer this question