We regret to announce that Road Test Reports will be closing down on 2nd October 2017

FORD questions and answers: find help and give advice

Ask and answer questions on a variety of FORD models. Help and advice on everything FORD. Feel free to ask and answer as many FORD-related questions as you wish.


Search the questions and answers section:

Below are the latest FORD questions answered by visitors to RoadTestReports.co.uk. To supply an answer yourself simply click on the "Answer this question" link underneath each question. Alternatively, if you want to ask a question, simply click on the link below.

Ask a question now

Joe Cardoso, Zimbabwe

Ford Ranger

I have a 2007 3.0 Tdci Ranger that has a loss of power/torque above 2500 RPM. The Common Rail pump, injectors were replaced 6 weeks ago and two weeks later the Turbo failed and has been replaced. A friend has looked at the Vacuum system pipes and suspects that the problem may be a result of incorrectly connected pipes. It looks like there is one pipe fitting/tail on one of the Vacuum tanks that is not connected. I have not been able to find a schematic of this vacuum system online to guide me, and would be grateful for any assistance in sourcing one and some advice on the matter.

Answers

I would like to get feedback.dont know if im imagining but feel like bakkie got less power than before. Stephan from South Africa

Submitted: 17/09/2016 00:47:18 | ID: 135221

Answer this question

Brian Young, Moray

Ford Transit Connect

My Transit Connect makes a lot of road noise, which varies with wheel speed, but not engine speed. Its a kind of buzzing or whining, and it increases from low pitch to higher pitch as I get faster. Maximum noise around 50 or 55 mph. I thought at first it was the front bearings, but it doesn't do that thing where the noise increases when you turn the steering wheel. And anyway both front wheel bearings were changed 3 years ago. Its not tyre noise either, as it doesn't change with the road surface. Any ideas?

Answers

Has your van got a roof rack on Michael from Antrim

Has your van got a roof rack on Michael from Antrim

still could be the wheel bearings....that what it sounds like to me. stewart from Suffolk

Could be the offside driveshaft bearing where it bolts to the engine these are common . About 20 quid on ebay or a shaft is more. Garry from Devon

Submitted: 15/06/2015 11:30:10 | ID: 117222

Answer this question

JOHN, Derbyshire

Ford Transit Connect

the glow plug warning light comes on while im driving and the engine stops

Answers

Not sure of your vehicle but the glow plug warning lamp is sometimes to warn you that the DPF filter is blocked. If it is, you would start running in limp mode and if you keep driving it the engine will eventually come to a stop. Hugh from City of Glasgow

Submitted: 13/07/2017 15:12:49 | ID: 142533

Answer this question

JOHN, Derbyshire

Ford Transit Connect

how do check the injectors on a 1.8 deisle engine

Answers

You'd best take it to a diesel service centre eg Bosch authorised service and repair shop. Taking the injectors out can be difficult and they require special test equipment to check them and set them up. Hugh from City of Glasgow

Submitted: 13/07/2017 15:22:50 | ID: 142537

Answer this question

Salim jussab, Malawi

Ford Ranger

I have a ranger 3.2 diesel 2014 model the car is failing to start after parking it whilst it was OK for some time the diagnosis it's bringing a code which shows low pressure to the injectors what can be the course? and what should I do?

Answers

hi pressure fuel pump has failed suggest replacing Steven Miller from New Zealand

Submitted: 18/02/2017 08:28:59 | ID: 139001

Answer this question

Adrian Armsby, North Yorkshire

Ford Transit

Driving along it gets to about 50mph oil light comes on for a prox 3 seconds and goes into limp mode for about 20 to 30 yards and then ok for rest of journey . Then the next time out the same again . Any thoughts .many thanks Adrian

Answers

You need to get this looked at and checked out ASAP, you did not say what year your transit is but I know some transit customs have oil pump recalls and some have destroyed engines due to lack of oil pressure. Your local Ford dealer should be able to advise you of this. If is not this is your engine oil ok? Sounds like engine low oil pressure, remembering your timing chain tensioner is oil fed ! Be careful you don't destroy your engine! John westwood from Essex

Submitted: 15/06/2017 21:44:51 | ID: 141964

Answer this question

garry, Cheshire

Ford Transit Connect

hi my 2004 connect l220td keeps going into limp mode ie glow plug light flashing,mainly over 3000rpm ...turn off and back on fine for a few miles ,any ideas ,thanks.

Answers

I had this problem and it needed a new accelerator pedal. Got one from eBay and fitted myself, works a charm. Martin from Norfolk

Submitted: 13/09/2016 21:07:28 | ID: 135163

Answer this question

Sam Godfrey, England

Ford Transit Connect 2006

I have a Ford Transit Connect 2006 plate. The display dash flickers, no speedo reading, no fuel gauge reading, no rev counter reading and no temp gauge reading. The internal light flickers and relays behind the glove compartment clicks. Everything runs as normal when this happens. Does anyone know what the problem might be?

Answers

Had the same problem, dash flickers, no gauges work. I took it to Ford, new speedo fitted and programmed into van memory costing £900. Ford recognised this fault on the Focus and will repair them cheap, but sorry not on the Connect. Peter Fotheringham from Fife and Kinross Shires

Peter im afraid your clocks were fine. You just had bad connection too and have been fobbed off. nik from Kent

I have a 56 plate connect . My dash lights went and all the rest of instrument panel . It was dust and a loosened plug in . Which is located behind the speedo panel at the back . unclip it , which can be a bit tricky . There are 2 clip on them , then give it a blow out and the check . A small paint brush can bet used. Rather than your spit lol . Good luck , hope this helps you , out . Blue from East Sussex

Submitted: 25/02/2014 08:56:06 | ID: 62069

Answer this question

Tracy weston , Hertfordshire

Ford Transit

I have 2004 tipper Transit with the dash mounted c Controller panel the controller turns on tells me To refer to manual before proceeding after 10/12 Seconds turns itself off can't press any buttons

Answers

If you google Control panel for 2004 tipper Transit you will find the whole manual available for the tipper control. An extract reads "Energise System: Park the vehicle and apply handbrake, Turn isolation switch to ‘ON’ position, Switch on the Tipper Control system by pressing green ‘ON’ button, Green ‘system energised’ light adjacent to switch will illuminate, Note: If you release the handbrake after pressing green ‘ON’ button a warning will sound and green ‘system energised’ light will extinguish and Tipping will no longer be possible. Reapply handbrake and reset ‘ON’ button" Hugh from City of Glasgow

Submitted: 15/05/2017 19:17:08 | ID: 141314

Answer this question

Dave Durant, Suffolk

Ford Ranger 2007

My Ford Ranger`s exhaust is blowing black smoke when I`m accelerating. What can I do?

Answers

My Ranger is blowing black smoke when I ex celerate. Riaan Schulze from South Africa

Submitted: 22/11/2013 12:23:53 | ID: 58484

Answer this question

Pieter, South Africa

Ford Ranger

Hi.when I drive I can only drive uder 2500 rpm when the engine is under 2500 rpm it drives ok but there is no boost from the turbo when it reches 2400 rpm it surges like im driving on limp mode what sensprs can I replace because I have already replaced the turbo boost sensor and it made no change. The check engine light stays on the engine starts ok. Yesterday when I was driving to town the engine died on me but I got it started and drove on further. Please I need urgent help.

Answers

It would certainly have helped if you had stated what year your vehicle is and which engine is fitted. Hugh from City of Glasgow

The ford ranger is a 2008 3.0tdci duratec ford. Motor it has a comon fuel rail engine Pieter from South Africa

It's not an engine I'm familiar with but some Fords have trouble with the electronic throttle body aka throttle position sensor. The throttle position is driven by a stepper motor which is controlled by an integrated circuit within the throttle body. The printed circuits are prone to sometimes intermittent failure as is the integrated chip. Modified units are available. As a matter of routine you should clean the MAF sensor and see if it improves. If it does not, disconnect the MAF sensor and run the engine. Some ECU's have a default setting which will allow them to run, if this is an improvement then fit a new MAF sensor. I have also heard of a problem with camshaft dephasers which are not supposed to work above 2,500 rpm but sometimes do, causing misfiring and loss of power. Unfortunately do not have any data on that. If your engine is non-VVT then I don't think it will have camshaft dephasers. Have you had this vehicle scanned for fault codes? Remember some cheap scanners will not read manufacturers fault codes so use proper tool or have garage check it. Hugh from City of Glasgow

I repaired 2 broken wires but fault still there. What else can I check I had the engine on diagnostics and it said turbo boost circuit open the engine cant go past 2400 rpm. Pieter from South Africa

The diagnostics said the throttle positioning sesors are ok Pieter from South Africa

When you had it diagnosed what fault codes were you getting? If you still have the fault code(s) held in memory then you need to clear them. After you repaired the wiring did you check the complete circuit between the sensor and the Powertrain Control Module? The feed, earth and 5v signal output circuits, it’s quite possible there are other faults.in the circuits. Have you been trying to adjust the link between the turbo VNT control ring and the vacuum diaphragm? The only way you can adjust that is on a flow bench otherwise you can damage the turbo. Are you sure the engine is not in limp mode when it won’t rev above 2,400? This could be caused by a number of things like the EGR valve stuck open or the DPF being choked. Hugh from City of Glasgow

Submitted: 26/03/2017 11:38:09 | ID: 140161

Answer this question

Eugene, South Africa

Ford Ranger

I've got a ford ranger 3.0 tdci 2010 it cuts out after 3000rpm in 4 and 5 gear and then needs to restart I took it to the agents and they pluged it in and shows it is a internal feul leak said I need to replace the feul relay they put in part R8000 and still does the same thing now they say its the feulpump R16000 I didn't paid them and said I will find nother answers please help

Answers

I have exactly the same problem. Did you get a fix? Once the vehicle stops I turn the key off then it starts up straight away. I don't think its losing any rail pressure as it starts up with not too much cranking. We have checked the fuel lines, breathers etc. There are no fuel leaks. Keen to know what you found? Jonathan Crocker from New Zealand

I have exactly the same problem. Did you get a fix? Once the vehicle stops I turn the key off then it starts up straight away. I don't think its losing any rail pressure as it starts up with not too much cranking. We have checked the fuel lines, breathers etc. There are no fuel leaks. Keen to know what you found? Jonathan Crocker from New Zealand

I might be able to help you. I had a similar problem on my 2007 3.0 TDCI. Mine would cut out but always re start. Changing fuel filter would sometimes cut down the frequency of the problem. Ford said there was a problem with after market filters so shelled out £35 for a Ford item....there was an improvement for a very short while but then the problem returned. Tank was drained many times looking for sediment, nothing. In frustration I paid for a proffesional diesel diagnostics company to check it over and even they failed to locate the problem. After 4 years of living with the problem changing filters every coiuple of weeks, the frequency of it cuting out eventualy made the truck undrivable, every couple of hundred yards . I decided there must be a logical explanation. All the symptoms pointed to diesel starvation. So,to eliminate components I set up a seperarte feed tank with a in-line filter and new feed pipes. problem was still there. I then removed the in-line filter, still no sucess. But it would always start and run perfectly until any load was put on it. At this point I was now resigned to purchasing another vehicle. But not wanting to let it defeat me, a thought crossed my mind. On weber carbs there is a cage filter in the banjo bolt that secures the fuel line to the carb. Might be worth checking. The fuel line is secured to the fuel pump by a banjo bolt. I removed this. I tried to blow through it and there was quite a restriction. In the base of the bolt (they are hollow to allow fuel to flow) I could see a very fine mesh pressed in filter about 2mm dia . Could this be the problem? I placed the bolt in a cup of carb cleaner and then tapped it, nothing at first , then a cloud of tiny black particles appeared, I could now blow through the bolt easily....Eureka Truck now never misses a beat . I think that changing the main filter always just offered a little less restriction to the fuel getting to where the partial blockage was. But eventually this was not enough. Pity there is nothing on on the ford diagrams to show this filter and the so called experts do not seem to know it exists. How many pumps and other parts have been changed to solve similar problems ? Hope this helps. Regards David david savage from City of Edinburgh

Submitted: 16/04/2014 20:35:30 | ID: 94332

Answer this question

MARK SHEPHERD, Durham

Ford Transit Connect

Hi ive just brought a ford transit connect t200 2002 model when i accelerate to about 4000 rpm i get a loud whinning noise and what seems to be a blowing sound like the exhaust,,had it to my local garage but they dont know either ive changed the turbo pipes and inter cooler ones please help me any ideals what i do next

Answers

Diesel engines do not like being revved too high, there's no point since the torque output falls off a cliff as it approaches 4,000 rpm Hugh from City of Glasgow

Submitted: 06/04/2017 18:16:17 | ID: 140456

Answer this question

gavin, Norfolk

Ford Transit

my tipper went up a short way then stopped suddenly and will not go up or down

Answers

If the tipper rose on its own then it sounds like the valve which controls the ram is faulty and has now stuck so the ram won't come back down. Warning: if you are going to disconnect the ram or any of the hydraulic control system make sure that the body is supported with strong timbers. Hugh from City of Glasgow

Submitted: 08/02/2017 19:15:51 | ID: 138805

Answer this question

Tracy, Kent

Ford Transit

My van drives nice until you come to a hill and you put your foot down a bit cuts out haveit cut out have to start it up again

Answers

Check temp when it happens if it's up it's a new water pump had the same problem Don from Lancashire

Submitted: 24/01/2017 11:27:17 | ID: 138370

Answer this question

David Curran, Ireland

Ford Transit Connect 2006

My Ford Transit Connect`s dash stays illuminated even when the keys are out and the lights are off. I have been told this is common or even meant to happen. It does not go out at all but stays on all of the time. Any ideas?

Answers

Did you sort the light illumination fault? I`m after ideas Gary Foster from England

No joy on it still staying lit up David Curran from Ireland

I'm having the same problem can anyone help????? gary confrey from Scottish Borders

Drivers side footwell there is a plastic panel to the right hand side, remove the panel there is an electrical connector behind that panel which is bolted to the piller with a 10mm bolt. Undo the bolt pull the connector apart you will find water has got in there. Dan shroll from Monmouthshire

Submitted: 30/10/2012 10:42:15 | ID: 89140

Answer this question

Chris, South Yorkshire

Ford Transit

Hi I have a 07 mk7 transit, it struggled to turn over in a morning very slow but never failed then would start ok all day. I changed the battery but no change, a friend told me it may be a lazy starter motor so I have put a new starter motor on and it turns over great but won't start now? Can any one help thanks

Answers

Hi i have the same thing on my ford transit if I find out i will let you know. I think it might be the duel mass flywheel ? Andy from Somerset

Submitted: 04/10/2014 15:57:31 | ID: 104055

Answer this question

Andrew, Hampshire

Ford Transit

Hi , my 06 t350 has a problem with the headlights , only full beam works but bulbs are fine so are the engine compartment relays and fuses there also appears to be no fault with the paddle or rotary switch . It maybe coincidental , but the reversing lights have also failed , could this be a bad earth , if so , where are the likely places to find them or do you have any other suggestions , Thank you in advance Andrew

Answers

dipped beam relay gone at back of glovebox £4.00 from motor factors £30.00 from ford simon bounds from Herefordshire

Submitted: 20/01/2017 08:23:44 | ID: 138259

Answer this question

samuel, Barbados

Ford Ranger

Hi, Is it necessary to re torque the cylinder head of the 2007 Ford Ranger Thunder after a new head has been installed? If the answer is yes, what are the torque settings? Thanks.

Answers

Which engine do you have? You should use new cylinder head bolts. The 3 litre engine for example had Torque to Yield bolts which are tightened in stages and do not require re-tightening. Stage 1 you tighten the bolts to 25 lb/ft Stage 2 tighten them to 53 lb/ft Stage 3 tighten them an additional 90 degrees and finally Stage 4 tighten them an additional 90 degrees. This puts the bolts in the correct elastic strain range, any tighter will put them into the plastic stage where they will suffer elongation and lose clamping force. Hugh from City of Glasgow

Submitted: 23/12/2016 23:06:02 | ID: 137561

Answer this question

chris, Essex

Ford Transit

hi my 2008 transit swb mark 7 has developed a fault,while ticking over,it suddenly revs on its own,for a short while before returning to normal as this can happen at traffic lights it is quite a worry.any suggestions please,the van has done about 150,000 miles.thank you chris.

Answers

Possibly the I,n,v valve in the fuel rail brian from Essex

Check idle valve first, then all other electrical connections on the various sensors. I had this with a KA where the water temp sensor connection was intermittent. Paul from Cambridgeshire

Submitted: 30/08/2016 21:42:30 | ID: 134773

Answer this question

Paul Caulfield, England

Ford Transit Tipper 2006

I have a mk 6 Ford Transit Tipper and the Tipper control unit on top of the dash has no power getting to it, so it will not turn on. I have checked the fuse under the driver`s seat and that`s okay, so how do I find the other fuses. Under the tipper is a plastic box, has that got fuses in it? Can someone help please? It was fine last week and I`ve not touched a thing.

Answers

Hi did you manage to get your Tipper to work as I'm having similar issues with mine? Everything was fine, it`s a 57 plate. I have no power at the switches and can't find a fuse. I have been looking and it's nearly a week and it's doing my head in. I`ve checked all of the wires behind the switch and all seem fine, the buzzer was working when I switched it on but now nothing! Thanks Darren from Essex

hi there is 2 fuses in the white box underneath the bed that has the live feed for the tipping control box in the front of the truck the easiest way is to go underneath the bed and bridge the main feed to hydraulic pump across the solenoid to the other large post this will cause the bed to raise then prop the body and get at the fuses also make sure the isolation switch is on and test all the wires for live . lee from West Sussex

Submitted: 24/03/2014 16:02:11 | ID: 62141

Answer this question

Raymond Hayfield, England

Ford Transit Connect 2006

I have had my Ford Transit Connect from new in 2006 and it has done 1000,000 miles. When I try to put the van into reverse it won’t go in and I have to play about with the gears before it finally goes into reverse. All of the other gears are fine and I`ve never had a problem before. The mechanic says that it needs a new gearbox. He did lift the bonnet and spray the cables where they join on to a ball joint. Can someone help me out please? (T230 tdci)

Answers

Lift the cover from round the bottom of gear stick where stick goes. Into box with oil can squirt oil in while moving gear stick so as to get oil in don’t be shy with oil it might work it did for me Ian Russell from Dumbartonshire mob 07976561725

Hi take air filter out of the way and battery jack up gearbox take of gearbox mounting take of selector bolts,and check roll pin in selector common problem. Time roughly 11/2 hrs. DIY job. John from Swansea

Submitted: 25/06/2012 09:29:45 | ID: 88163

Answer this question

Ken Thompson, Devon

Ford Transit Connect 2006

The serpentine belt partially broke and the Ford Transit was driven for 5 miles approx. I could hear a ticking noise when driving but as the engine didn’t overheat I chose to drive home. I replaced the belt and now have an oil leak. The split belt must have damaged the oil delivery system. Any ideas where to look?

Answers

Hi some of the rubber off the belt has gone in to the crank oil seal remove old rubber, otherwise chainge crank oil seal. John from Swansea

Submitted: 24/02/2012 10:43:47 | ID: 80048

Answer this question

greaves, South Yorkshire

Ford Ranger

The fuel pump is leaking on our Ford Ranger Thunder D/C 4WD 2007 pick up. 2 mechanics have been unable to remove the pump, any advice please? The engine is a mazda and the pump is a bosch.

Answers

Hello the best place to have your pump looked at is feather diesel elland near Huddersfield I've used them but they're not cheap I have no connections with this company Mark nicholls from South Yorkshire

Submitted: 30/06/2016 11:59:52 | ID: 133127

Answer this question

Terence, Yorkshire

Ford Transit Connect

1.8 tdi transit connect......heater light flashes then goes into limp mode then cuts out but starts back up then does it again

Answers

We had a problem with our 53plate transit connect, the heater light would flash then stop completely, usually when dropping a gear and over taking, switching the key off and back on would get it going again, this problem would always result in the van not starting the next day, and the only way we could get it to go was with easy start, after numerous no starts and a whole tin of easy start, we had the van tested for injectors and after replacing a F--ked injector the van has worked ok, We are just about to clock 250k in this van so can't complain Ian from Warwickshire

Submitted: 06/06/2016 21:30:25 | ID: 132415

Answer this question

tony, Brighton & Hove

Ford Transit

any body had were she just dont like hills, like even small ones ,first or second foot down power lose help needed doing my nut.

Answers

intake manifold probably split, they are a glued 2 piece plastic, common problem drill holes in top edge bolt with washers will never happen again Niven Muir from New Zealand

Submitted: 22/07/2014 00:27:20 | ID: 100135

Answer this question

Mr Bggs, Kent

Ford Ranger

Hi I have a ford ranger 2013 i notice white smoke today, pulled over and checked the water and oil. The oil was low so i topped it up then started it up and the oil light stayed on then it went into limp mode can anyone advise me please cheers. Mr Biggs

Answers

Suspect oil pump failure causing turbo failure brian from Essex

Submitted: 17/08/2016 23:38:06 | ID: 134430

Answer this question

minnie, West Sussex

Ford Ranger

hi. i have a 2012 ford ranger with the oil light staying on and engine making a funny noise.iv checked the oil but its ok and im not loosing any,would changing oil filter make any difference as i dont think its had a service.

Answers

Check oil pressure unit at oil filter casing. And if that not the problem take it for a oil presure test to see if oil pump is working. 80% thats the problem. If your vehicle has done more than 70 000 km John Krugel from South Africa

If its a 2.2 it has suffered from a global puma oil pump fail, there is a possibility that ford may warrant a repair even if out of warranty. Most early transits with the euro 5 engine suffered engine failure due to this for transits the field service action code is 4s616 brian from Essex

Submitted: 29/06/2015 13:16:09 | ID: 117833

Answer this question

Damian Powell , Blaenau Gwent

Ford Transit Connect

Hi I drove my connect 80 miles today with no issues whatsoever but when I stopped it for 10 minutes it would not start again it's turning over but not firing any suggestions thanks

Answers

Hi put key in ignition and turn it 10-12 times from point zero to full ignition mode quickly (DO NOT START ENGINE) you will hear the central locking lock then unlock it has the reset your default settings in the ECU try again.. GOOD LUCK GARY from Merseyside

Submitted: 13/08/2016 18:29:21 | ID: 134337

Answer this question

Larry moat, Tyne and Wear

Ford Transit Connect

Red light on dash is flashing nothing else lights up when i turn key in ignition .my van has been refusing to start on several occsions but the dash always lit up.could this be an immobiliser problem.thanks for any advice on this problem

Answers

Any electrical issues such as red light flashing (immobiliser fault) but with any multi functional issues try this... Stop your vehicle apply handbrake.. right take out key from ignition wait for 5 seconds the re-insert key into ignition then turn the key 10-12 times constantly from position zero to ignition lights (DO NOT START) just turn the key and you will here central locking unlock and re-lock this is then when the turns have re-set the settings in the ECU... Try again and see if all returns to normal running... many times this can reset engine management light and other limp mode lights illuminated on the dash. HOWEVER this is not a problem solver this is purely a system reset to see if problem goes away or returns...Good Luck GARY from Merseyside

Submitted: 08/05/2016 09:06:54 | ID: 131293

Answer this question

Pieter, South Africa

Ford Ranger

Hi. I have 2008 ford ranger tdc3.0 lxf it start ok but will not Rev over 2500 rpm it's very anoing. The check engine light stays on when this happens sometimes it comes ok by its self. Please somebody help me I need to know which sensors to replace.

Answers

Hi Pieter Kyk bietjie wat gebeur as jy jou diesel cap afhaal. Pietman from South Africa

Submitted: 31/07/2016 08:11:30 | ID: 133987

Answer this question

rich, West Yorkshire

Ford Transit Connect

hi i have a 2008 transit connect tdci and when driving it between 1800-2000 rpm it jerks. if i drive the van hard so the van is driving above 2000 rpm no jerking. i have fitted new diesel filter and new egr inlet manifold and it still jerks between 1800 & 2000 rpm

Answers

I've got the same problem I think- if I drove it like a rally driver it'd probably be ok but to drive normally it does it- engine management light comes on occasionally and shows up an egr fault- I think it gets full of soot and needs changing. Have you got yours sorted? Carl from Oxfordshire

Submitted: 23/04/2016 14:50:28 | ID: 130720

Answer this question

Rick johnson, Buckinghamshire

Ford Transit

How to replace faulty sender unit

Answers

More info needed R Evans from Caerphilly

Submitted: 25/08/2016 19:19:26 | ID: 134647

Answer this question

Mr Ian carey, South Yorkshire

Ford Transit Connect

Hi had my transit connect to auto electrician New battery goin flat, he pulled s fuse which blanks the clock n mileage counter, connected battery back up and drove home following morning battery flat again ive been told it could be alternater but had it checked its OK, also could be starter motor fault or the head is non presurising o something like that. Can anyone help thanks ian

Answers

I had the similar problem on my 2004 lwb 220 connect, it was the alternator wiring harness loom which had perished due to water ingress, the auto electrician showed me the wiring loom and you could literally break the wires just by pulling them.. Repair cost £120.00 inc vat harness from ford should have been £35.00 + vat but electrician made the loom on the job as he said the genuine ford replacement wasn't long enough to replace the damaged wires, I've posted this issue regarding the amber light on the dash but could also be the same fault as the auto electrician said its more common for the battery light to eliminate therefore had a nightmare diagnosing my fault as no fault codes came up in the diagnostic stage ...Hope this helps, Martin from West Midlands

Submitted: 08/05/2016 21:00:39 | ID: 131319

Answer this question

Marc Goring, Derbyshire

Ford Transit Connect

Hi, Just a quick question or two :) 1 - the battery light comes on every now and again on the dashboard- is this a low battery or something else? 2 - Do any of you chaps push the clutch in prior to turning the ignition? Thanks Marc

Answers

I had the similar problem on my 2004 lwb 220 connect, it was the alternator wiring harness loom which had perished due to water ingress, the auto electrician showed me the wiring loom and you could literally break the wires just by pulling them.. Repair cost £120.00 inc vat harness from ford should have been £35.00 + vat but electrician made the loom on the job as he said the genuine ford replacement wasn't long enough to replace the damaged wires, I've posted this issue regarding the amber light on the dash but could also be the same fault as the auto electrician said its more common for the battery light to eliminate therefore had a nightmare diagnosing my fault as no fault codes came up in the diagnostic stage ...Hope this helps.. Martin from West Midlands

Submitted: 28/06/2016 09:49:39 | ID: 133058

Answer this question

Andy walton, Lincolnshire

Ford Transit Connect

Hi , the amber engine light keeps flashing like a loose connection , and is not showing and fault codes on a upto date snap on fault reader , do you have any idea what could be the problem . Thanks andy

Answers

I had the same problem on my 2004 lwb 220 connect, it was the alternator wiring harness loom which had perished due to water ingress, the auto electrician showed me the wiring loom and you could literally break the wires just by pulling them.. Repair cost £120.00 inc vat harness from ford should have been £35.00 + vat but electrician made the loom on the job as he said the genuine ford replacement wasn't long enough to replace the damaged wires...Hope this helps.. Martin Martin from West Midlands

I had the same problem on my 2004 lwb 220 connect, it was the alternator wiring harness loom which had perished due to water ingress, the auto electrician showed me the wiring loom and you could literally break the wires just by pulling them.. Repair cost £120.00 inc vat harness from ford should have been £35.00 + vat but electrician made the loom on the job as he said the genuine ford replacement wasn't long enough to replace the damaged wires...Hope this helps.. Martin Martin from West Midlands

Submitted: 20/07/2016 16:50:52 | ID: 133679

Answer this question

Jason Parsons, England

Ford Transit Connect 2003

Hi there. I’ve got a 2003 Ford Transit Connect and the battery sometimes goes flat overnight. I’ve checked the alternator and that’s charging the battery okay and I’ve had the battery tested and that’s okay, but I’ve noticed the digital clock, mileage and trip mileage are staying on. Is this normal with the key removed from the ignition?

Answers

Try the starter motor my was doing same turned out starter motor Brett from West Yorkshire

I've got the same problem on my 06 transit leave overnight and goes flat I've tracked mine down to the intsrument cluster fuse 74 if you take mine out and then put it back in the light and radio come on then go out but soon as I open the door and close it it stays on the radio so it's constant drain I've left my fuse out to check if it is that I'll test my batteries to see if they are still draining but I. Positive it's that so I. Checking all doors are shuting correct Malcolm from Carmarthenshire

Submitted: 27/02/2014 10:12:58 | ID: 62377

Answer this question

Danny, City of Glasgow

Ford Transit

Anybody know how to turn off daytime running lights on my 2012 minibus

Answers

The short answer is you can't... It's now a legal requirement for all new vehicles to have day lights Jon from Blaenau Gwent

The short answer is you can't... It's now a legal requirement for all new vehicles to have day lights Jon from Blaenau Gwent

Hi mine are same i took the side orange markers cover off today and they was melting with having them on all time think ford need to change this before a fire starts Jams from South Yorkshire

Submitted: 17/04/2014 12:52:56 | ID: 94360

Answer this question

Marius, South Africa

Ford Ranger

Diesel mechanic changed cam belt kit and replaced 16 rockers. Engine pressure with valves are perfect and so the mechical side of the motor is 100%. When we crank the enjin, we do not get enough pressure on the injectors to fire and there is no mist spray. Could it be a faulty pressure release valve on the pump? Can I buy the pressure release valve sepperate from Bosch? Is it possible to service the valve?

Answers

We finally managed to get the enjin to start, but there is a diesel knock and after a minute the computer turns off the enjin. What could be the problem? Marius from South Africa

check pump timing martin from Essex

Submitted: 05/08/2016 05:39:13 | ID: 134121

Answer this question

Joe, South Africa

Ford Ranger

My ford ranger 2013 model won't start with key.It only starts with a push & makes noise like a of a bearing knock of petrol cars especially after revving it.What may be the problem?

Answers

Sounds to me like injectors, have you had them tested? Ian from South Africa

Submitted: 14/07/2016 17:27:37 | ID: 133525

Answer this question