We regret to announce that Road Test Reports will be closing down on 2nd October 2017

MITSUBISHI (VANS)

SWITCH TO CARS

Questions and answers

MITSUBISHI L200 questions and answers: Page 5

Mitsubishi L200

Ask and answer questions on a variety of MITSUBISHI L200 models. Help and advice on everything MITSUBISHI L200. Feel free to ask and answer as many MITSUBISHI-related questions as you wish.

Ask a question now


Search the questions and answers section:

Below are the latest MITSUBISHI L200 questions submitted by visitors to RoadTestReports.co.uk. To supply an answer, simply click on the "Answer this question" link underneath each question. Alternatively, if you want to ask a question, please use this simple form. Please try to make the question as detailed as possible, with all the information necessary for a comprehensive answer included. Please do not use "text speech" or type everything in CAPS LOCK.

John, Ireland

Mitsubishi L200 2004

Hi. I have a Mitsubishi L200 warrior that has developed a problem over the last few days. When cold starting she starts up fine, but there is like a knocking that comes into first thing, it`s a bit like a cracking/tractor noise and after a few minutes it`s gone and it drives fine. When I noticed this noise I checked the oil and I had to put in about 1l to bring it up to the full mark. Last oil and filter change was 6 months ago. It also stalled on me the first time I heard it, first time ever, when I pulled from a parking spot, it was like it didn`t respond to the throttle. The oil pressure has been checked and it`s fine. I also changed the oil and fuel filter as well. Does anyone have any ideas for me? Thanks.

Answers

From my knowledge when a car picks up a knocking sound on starting then goes normal the oil pump is faulty and needs replacing. Funktastic from Central African Republic

Submitted: 25/02/2014 09:02:26 | ID: 61797

Answer this question

Nkwachi, Zambia

Mitsubishi L200 2008

I have a 2008 Mitsubishi L200 warrior. Firstly the engine light came on so I took it to the mechanics and I was told the booster pump malfunctioned and that has been corrected. A few days later it came on again, the OFF ROAD lights came on and the vehicle started labouring when accelerating. The gas pedal had to be stepped on fully and the speed limiter was going to 3000rpm so I took it back and I was initially told it is the turbo that has a problem. They opened it but they found no problem. Now they are talking of the ECU being faulty. I have lost confidence in the mechanics looking at the problem. Does anyone have an idea? (Warrior)

Answers

Hi, have you got an upgrade kit on it? If you have then get it off. I have 3 of them now all new shapes di.d and all had the same problem. When put on code reader coming up low flue rail inlet gasket and other things, Mitsubishi wanted £2.700 to fix. I had upgrade kit taken off and problem solved on all 3. Talking to main dealer the other day he said they`re no longer going to fit them. Hope this helps - easy job, just unplug and put plugs of all loom back on, job done dean from Kent

Submitted: 18/02/2014 14:33:47 | ID: 62213

Answer this question

Terry Keem, Kent

Mitsubishi L200 2007

I replaced the interior bulb on my Mitsubishi L200 and now it does not work, nor do the radio or clock either. What could be wrong?

Answers

Blown fuse, replace and it should be fine. John Price from England

Submitted: 18/02/2014 12:40:21 | ID: 62202

Answer this question

Ariel Escolin, Ireland

Mitsubishi L200 2008

Good day. I have a 2008 Mitsubishi L200 automatic which has done 190,000 kms now. The problem is that there`s a big vibration in the engine every time you apply gas and this vibration is in the gas pedal, steering wheel and the whole body. Can anybody please help me? Many thanks.

Answers

Sounds like the balancer belt to me. Les from Middlesex

Get the garage to check the counter balance shaft belt. My L200 Animal (Automatic) sheered all the teeth of the belt. It was making a pulsing throbbing noise that makes you feel sick and you can feel the vibration through the gearstick. I would advise you don't drive the vehicle as this belt could end up taking out your cam belt and maybe even your engine. Jane Craig from Bedfordshire

Submitted: 11/02/2014 10:18:57 | ID: 61988

Answer this question

Sheila Evans, Yorkshire

Mitsubishi L200 2007

I have bought a hard back for my Mitsubishi L200 but can`t find out how to remove its soft cover. Can anyone help please? (Animal L200.)

Submitted: 07/02/2014 11:53:32 | ID: 61822

Answer this question

Tracy Walkden, Lancashire

Mitsubishi L200 2000

My Mitsubishi L200`s fuel lines were corroded and it was leaking diesel. I had new pipes put on but the fuel is tracking back to the tank when the car is standing. Does this mean there is air in the fuel system and if so, how do you get rid of it? Cheers.

Submitted: 30/01/2014 10:48:22 | ID: 56843

Answer this question

Edward Davis, England

Mitsubishi L200 2003

I have a Mitsubishi L200 Warrior on a 53 plate. When I turn the front fogs on, without any lights on at all, the side lights and dashboard lights come on but the fog lights do not. I have checked fuses but don`t believe they are blown anyway as the operation of the switch is live, albeit on the wrong lights. Before I get to the re-tracing the wire stage, has anyone else come across this problem? Is it a simple fix I am missing? Thanks in advance. (L200 Warrior)

Submitted: 16/01/2014 15:34:22 | ID: 60754

Answer this question

John Humphreys, Orkney Islands

Mitsubishi L200 2001

I have a Mitsubishi L200 Animal. When you try to start it it winds over but makes a clunking noise every time the starter motor turns it over. It`s not big ends or it would not do that untill it started. Any ideas please? (animal)

Answers

If it’s just on crank it’s either the starter motor itself or the flywheel. Remove and inspect starter first, damage will probably be obvious, if not it’s gearbox out.  Martin (Master technician 20 + years) from Durham

Submitted: 03/01/2014 14:12:33 | ID: 60204

Answer this question

Robert Jenks, Warwickshire

Mitsubishi L200 2003

My Mitsubishi L200 has oil leaking from the front of the engine, I think it may be the front crank seal? I checked the camshaft seal is okay. Are there any other seals eg. idler shafts with oil seals at the front? Sump gasket seems okay. Has anybody got any ideas where else the oil can be coming from, but I think the crank seal is the favourite? (Warrior)

Submitted: 02/01/2014 12:40:49 | ID: 60050

Answer this question

Steven Fyffe, Fife and Kinross Shires

Mitsubishi L200 2006

After driving through a shallow puddle at speed my Mitsubishi L200`s engine was spluttering going up hills . It would rev okay when the clutch was dipped but with load on the engine it was missing and spluttering . Can anybody give advice please? (Animal)

Submitted: 20/12/2013 10:13:35 | ID: 59526

Answer this question

Jim Maitland, Suffolk

Mitsubishi L200 2002

What is the plate on the side of my Mitsubishi L200`s engine block for? It is leaking oil. (K74)

Answers

A common MOD for the L200 is to blank of the EGR, this plate you’re talking about could be such a MOD. If it’s leaking oil it may need a gasket replacing under the plate? Edward Davis from England

Submitted: 25/11/2013 15:16:25 | ID: 58535

Answer this question

Merv Oxley, Somerset

Mitsubishi L200 2004

Hi, I have recently had a recon engine in my Mitsubishi L200 due to the original one blowing up, the injectors blocked and filled the sump with diesel. I`ve had the injectors serviced and put back in, oil changed and filter done, but now the engine is not running right at all and seems to be blowing diesel out of the injectors and blowing thick black smoke out of the exhaust. Is the engine screwed again? Are the injectors not timed properly? (animal)

Submitted: 21/11/2013 10:51:15 | ID: 58198

Answer this question

James Hardley, England

Mitsubishi L200 2001

My Mitsubishi L200`s amp meter is off the scale and the dashboard lights are brighter than normal. A new battery was installed week ago, the headlights were not working properly. What`s causing these problems?

Answers

Regulater/rectifier I reckon? If it is that it will be cooking your battery. I’d get it seen to asap. Hope that helps? Rich Rich from England

Submitted: 19/11/2013 15:24:49 | ID: 58101

Answer this question

Edward Kearney, County Tyrone

Mitsubishi L200 2003

What drives the rev counter on my Mitsubishi L200?

Answers

The crank angle sensor. Bob hat from Hampshire

Submitted: 11/11/2013 12:36:05 | ID: 56723

Answer this question

Iain Gleave, Staffordshire

Mitsubishi L200 2008

Hi guys. I have a 2008 Mitsubishi L200 warrior and had to disconnect the battery last week. Now the central display constantly says turn key to on position to check system, but nothing else happens. This also applies to when the engine is running, the screen stays the same. Any ideas please? Cheers. (Warrior)

Submitted: 05/11/2013 12:15:12 | ID: 57399

Answer this question

Fadi, Angola

Mitsubishi L200 2010

Hello, is there any way to find out where the interior lamp fuse is located in my Mitsubishi L200? I was mounting a new stereo and it seems that I sparked a fuse and I can’t find it?

Answers

In engine compartment fuse board 10 amp on left Wavey from England

Submitted: 05/11/2013 11:09:46 | ID: 57368

Answer this question

Chris Sloane, England

Mitsubishi L200

Where is the fuse box for electric mirrors on a 53 plate Mitsubishi L200 or what else could be wrong with them as they just stopped working?

Submitted: 05/11/2013 11:00:05 | ID: 57367

Answer this question

Jeff butt, Cyprus

Mitsubishi L200 1990

Is it difficult to refurbish the diesel injector pump and steering pump on my Mitsubishi L200?

Submitted: 01/11/2013 11:57:37 | ID: 57108

Answer this question

Chris Moss, Surrey

Mitsubishi L200 2005

I`ve just purchased my first Mitsubishi L200 which test drove fine, but 50 miles into the drive home and pulling up behind a traffic jam on the motorway my tick over idle became lumpy. It does not affect pulling away or general acceleration etc. What could be causing this? Also my engine is rocking from side to side slightly. I put this down to an old diesel but I am informed that Mitsy engines just don`t rock and roll. Is this possibly a worn engine mount? Thanks. (club cab)

Answers

Check your crank balancer. The l200 has 2 belts under the timing cover, see if one has snapped. Good luck. Thomas Jones from Neath Port Talbot

Submitted: 29/10/2013 15:55:31 | ID: 56981

Answer this question

Luke Palmer, Suffolk

Mitsubishi L200 2008

My Mitsubishi L200 animal puffs black smoke when changing gear but is fine if if I turn it off after a little drive and turn on again. Any suggestions?

Submitted: 28/10/2013 16:03:45 | ID: 56861

Answer this question

Eugene Adams, South Africa

Mitsubishi L200 2000

I have a Mitsubishi L200 Colt bakkie 200i petrol . This vehicle just refused to start. I`ve replaced the module and the fuel pump in the tank and have also recoded this vehicle but still it doesn`t start. A mechanic says there is no pulsing on the injectors .Could anyone give me some advice? .Does the wiring on module have a pulsing wire that could be not connected or be faulty?

Answers

Hi Eugene, I’m really going through hell to get my Colt 200 highline started. I have done even more changes than you did with your one and it is still not starting. Please help me out if you got yours started, any advice will be highly appreciated. Zubair Essack from South Africa

Submitted: 28/10/2013 14:32:30 | ID: 56757

Answer this question

Clair Bateman, England

Mitsubishi L200 2007

My Mitsubishi L200 has a very intermittent fault which has stumped all the garages around here. It will lose power and jault or judder when you put your foot on the accelerator. It does not record any faults on the computer. It can do this one day, 2 hours later it will run fine and then maybe run for a few weeks or even 6 months, but then all of a sudden it will start playing up again. Once last year it conked out all together so I got the RAC to recover me. He followed me to the garage where he removed the air flow mass sensor cables. After he did that it was fine for 6 months. I then had a new one fitted a few weeks ago as it started again but to no avail. Any ideas? Oh it’s an automatic as well. Thanks.

Answers

Have a similar fault with my 07 plate auto Warrior. I spoke to Mitsubishi and touch wood it was only a blocked breather pipe coming out the right hand side of the engine rocker cover; it’s only a narrow pipe, which goes to an electrical connection. I cleaned it out and so far so good, it drives like a new truck. I hope this helps. Karl from Gloucestershire

Submitted: 28/10/2013 14:12:26 | ID: 56752

Answer this question

Andy Eastham, Lancashire

Mitsubishi L200 2002

My Mitsubishi L200 02 reg has had a new battery, new alternator and belts fitted about a month ago. It won`t start now and even when I jump started it it conked out straight away. Any ideas?

Submitted: 28/10/2013 11:16:51 | ID: 56577

Answer this question

Luke Palmer, Suffolk

Mitsubishi L200 2008

My Mitsubishi L200 animal automatic blows black smoke when changing gear. I`ve just had it serviced and it`s still doing it. Any suggestions?

Submitted: 28/10/2013 10:55:34 | ID: 85744

Answer this question

Gary Inglis, Dumfriesshire

Mitsubishi L200 2007

My Mitsubishi L200 sat for six days without moving. When I returned to the vehicle the passenger`s footwell had a puddle. I’ve had this problem off and on and the mechanics can’t seem to locate where the water is coming from. As far as I can see the door seals seem fine. Anyone any ideas? Thanks.

Answers

I had water coming in through the back window in my cab. I had to lift the carpets and strip the interior panels to find the leak. It was coming from one of the fixed glass panels on the rear window. A fine bead of silicone on outside of the window cured it. Water was traveling from this rear window to the front foot well under the carpet. Christopher Murray from Ayrshire

Submitted: 25/10/2013 16:23:35 | ID: 56514

Answer this question

Chris Chester, Durham

Mitsubishi L200 2004

Hi. I have a Mitsubishi L200 Warrior. It’s got a problem with smoking on tick over and runs a little roughly on idle but seems to drive okay, maybe a little under power but not too bad. Could this be the fuel pressure sensor on the back of the pump? Sometimes it doesn`t smoke but is still rough on idle?

Submitted: 25/10/2013 12:28:41 | ID: 55830

Answer this question

Stephen Scattergood, England

Mitsubishi L200 2006

The touchscreen trip information and climate details don`t work on my Mitsubishi L200. I don`t seem to be able to reset the fuel information and wondered if this can be rectified? The screen is responsive and all of the other actions can be used. Please advise? Thanks. (warrior)

Answers

Hi, Ive got the same problem and the same car and was wondering if you managed to find a solution? Thanks. Martin from Dorset

Submitted: 25/10/2013 12:15:30 | ID: 55828

Answer this question

Michael Forster, England

Mitsubishi L200 2007

My Mitsubishi L200 snapped it`s timing belt and broke 4 rockers which were replaced. The car started immediately and ran well until hot when it would not tick over or rev. I allowed it to cool til next morning when it started immediately and ran well until hot. I`ve had the electronics checked and crank sensor changed but it`s still not right. Any ideas? Thanks. (warrior)

Submitted: 18/10/2013 15:57:06 | ID: 56322

Answer this question

Richard Vaaltyn, South Africa

Mitsubishi L200 2001

I have a 2.4 colt 2001 16 valves petrol L200. The revs go high when I insert the air flow sensor plug. When I remove it they go lower. Must I replace the air flow sensor?

Submitted: 09/10/2013 22:42:02 | ID: 53480

Answer this question

Panagiotis Psomas, Cyprus

Mitsubishi L200 2004

I have a Mitsubishi L200 Warrior 2004. The problem I have noticed is that sometimes when I accelerate, even most times, the gas is fully pressed but the car doesn’t accelerate as it should (sometimes you can`t even feel it). Added to this when it happens the speed limiter is activated at 2000 rpm and when I change gear the car seems to work fine. Any suggestions?

Answers

Hi try a new fuel filter. My 08 plate was doing the same, I put a new filter in and  it goes like a dream now. Stuart Jones from Yorkshire

Submitted: 08/10/2013 14:58:54 | ID: 55846

Answer this question

Simon Roberts, England

Mitsubishi L200 2001

Hi there. My Mitsubishi L200 has started to overheat while driving at 70mph and when I slow down to 50-60 mph it goes back to normal. However I do lose power from where the turbo is meant to kick in at about 2000 rpm and have a whining noise when I accelerate. I have been told it could be the water pump not pumping enough water round at that speed. I`ve also been told it’s not that because the heaters inside my car are working. Any ideas? Kind regards.

Submitted: 07/10/2013 16:26:55 | ID: 55908

Answer this question

Andy Topping, Nottinghamshire

Mitsubishi L200 1997

My Mitsubishi L200 keeps blowing the glow plug fuse. I replaced it and attempted to start the engine with a fully charged battery. The fuse blew immediately and the battery was flat after about 3 seconds of cranking over. Has anyone got any idea of what`s causing it? (Pick up 4WD Turbo)

Submitted: 03/10/2013 16:20:25 | ID: 55791

Answer this question

Colin Searle, Angus (Forfarshire)

Mitsubishi L200 2005

When driving my Mitsubishi L200 at a steady 30/40mph for a few miles I hear a ticking type sound which disappears when I accelerate. It`s done 104,000 miles, timing belts last changed at 60,000. No loss of power and it still performs well. Oil and water are both okay. Any advice and guidance will be welcomed. Any suggestions please?

Submitted: 06/09/2013 15:57:04 | ID: 54085

Answer this question

Yared Demissie, England

Mitsubishi L200

My Mitsubishi L200 double cabin turbo charger pick up`s radiator water levels drop after driving very short distances and I have to fill the coolant reservoir. The heat gauge starts to go up and down while driving and doesn’t go down while the motor is idling. The oil gauge starts to blink when the heat gauge goes up. I have changed the radiator cap but there has been no change. Does anyone know what I can do please?

Answers

Have u checked the radiator pipes? maybe one of them is leaking. Patrick from Botswana

Submitted: 02/09/2013 09:36:43 | ID: 53846

Answer this question

Tony Mulholland, Hertfordshire

Mitsubishi L200 2007

Hi. The other day my Mitsubishi L200 over-revved with grey smoke coming out of the back. I stopped and turned the key off but the truck carried on running.. I have sent it to be repaired and they say there is diesel in the engine oil. How can this be?

Submitted: 29/08/2013 09:51:40 | ID: 53684

Answer this question

Charitha Jayanath, Sri Lanka

Mitsubishi L200 2012

There is a high pitched sound from my Mitsubishi L200 when the brakes are applied. It’s more like one metal surface is rubbed on another metal surface with a lot of power. I cleaned the liners of the brakes but the problem is still there and it is definitely not the sound of the ABS. This happens more when it’s a rainy day. What could the problem be? Please can anybody answer me? Thank you. (Warrior)

Submitted: 27/08/2013 11:01:41 | ID: 53645

Answer this question

Iain MacRae, Lanarkshire

Mitsubishi L200 2007

My 57 plate Mitsubishi L200 Warrior auto starts fine but then stalls if you come to lights or a junction while the engine is cold. It stalls when the engine is below operating temperature, but there`s no EML light and once heated up it has plenty of power. It started doing this occasionally and is now doing it every day so I have stopped using her. Any ideas would be welcome. She currently has half a tank of diesel. Any suggestions please? Thanks. (Warrior)

Submitted: 06/08/2013 15:38:53 | ID: 53383

Answer this question

Jason Carter, Wales

Mitsubishi L200 2010

Hi, my Mitsubishi L200 drives lovely with plenty of poke, but on low revs it sounds like it’s rattling. Maybe it`s a diesel noise or something loose in the engine? Any ideas please?

Submitted: 05/08/2013 14:47:55 | ID: 53304

Answer this question

Namso Udo, England

Mitsubishi L200 2006

The oil warning light in My Mitsubishi L200 2006 model will come on when I drive the vehicle for up to an hour, but goes off if I accelerate and on again if the engine idles. What could be the cause?

Submitted: 05/07/2013 09:14:39 | ID: 81728

Answer this question

Sean Brosnan, Nottinghamshire

Mitsubishi L200 2008

My 2008 Mitsubishi L200 cuts out at low revs now and then at traffic lights or if I start it with no gas. If I touch the throttle it starts fine. There`s no engine management light coming on to tell me there`s a fault and it`s getting annoying. Does anyone know what`s causing it please? (Warrior)

Submitted: 01/07/2013 11:00:54 | ID: 64045

Answer this question